Internet Explorer ne peut pas ouvrir le site http://www... Opération abandonnée !

Comment palier à ce problème et pourquoi il ce produit (IE)
mardi 9 octobre 2007
par  KreaComm’
popularité : 7%

Un bug et c’est le crash total sur votre site ?! Le message d’erreur "Opération abandonnée" s’affiche et le chargement de la page est stoppé ?

Ce "bug" qui n’en n’ai pas un ce produit sous Internet Explorer lorsque la page est modifiée via un script JavaScript AVANT le chargement complet de celle-ci. A noter que les versions 7/8 sont également aussi impactées par ce problème. (KB Microsoft #927917)

Un exemple simple

  1.   <div>
  2.    <script type="text/javascript">
  3. var newElem = document.createElement('foo');
  4.     document.body.appendChild(newElem);
  5.    </script>
  6.   </div>
  7. </body>
  8. </html>

Ce code ajoute un élément ’foo’ dans la balise body alors que celle-ci n’est pas encore fermée (lecture ligne par ligne pour le parser) ce qui provoque non seulement une alerte dans le rapport d’erreur IE mais aussi la plantage...

Solutions :

1) Placez le code posant problème en bas de page (juste avant < /body> par exemple)

2) Exécutez le code seulement lorsque la page est complètement chargée en utilisant un onload :

  1. window.onload=function()
  2. {
  3. // votre code...
  4. }

Toujours le même problème ?

Dans ce cas essayez les étapes suivantes et n’hésitez pas à commenter si vous rencontrez toujours cette erreur :

- Videz le cache :
Outils > Options internet > Supprimer... > Supprimer les fichiers
- Redémarrez IE... cela fonctionne ? Non ?! alors désactivez le JavaScript dans IE :
Outils > Sécurité, cliquez sur la zone concernée (Internet probablement) et sur Personnaliser le niveau... Ensuite dans la partie Script, décochez Scripts ASP.

JPEG - 370.8 ko

- Maintenant, rechargez la page, que ce passe-t’il ? Si la page s’ouvre alors c’est bien un problème de JavaScript (un chemin DOM erroné ?), bon courage dans ce cas ;)

Informations complémentaires :

Blog IE : What Happened to Operation Aborted ?

KB MS : BUG : Error message when you visit a Web page or interact with a Web application in Internet Explorer : "Operation aborted"



Commentaires



Logo de bheadman
vendredi 10 septembre 2010 à 12h18 - par  bheadman

Ouep merci ça fonctionne mais c’est une solution un bourrin tout de même, car lorsque le site est bien codé et compatible, JavaScript fonctionne bien (+ asp) et surtout que le problème est résolut pour ce site mais qu’en sera-t-il des autres sites qui utilise JS et ASP et qui sont bien foutu (qui fonctionne) ??

Mais bon, toujours bon à savoir.
Merci

Logo de Mr_SATAN
vendredi 9 octobre 2009 à 20h10 - par  Mr_SATAN

Bonjour à tous !

Comme beaucoup j’ai un petit problème de chargement sur IE... A l’aide de vos explications j’ai isolé le problème et il s’agit visiblement du script chargeant la Clearbox (< script src="clearbox.js" type="text/javascript">

Le problème c’est que si je le mets hors des balises HEAD, la page se charge bien sur IE mais les Clearbox ne fonctionnent plus sur Firefox... les joies de la compatibilité ! Notez que le site semble s’ouvrir chez certaines personnes... www.tenaciousdfrance.fr si vous voulez tester.
Est-ce que quelqu’un connaitrait une solution miracle ?

mercredi 19 août 2009 à 21h38

sa marche aussi pour moi j’ai enlever asp et je les remis et puit sa remarche meri a vous :)

jeudi 9 avril 2009 à 13h08

Un grand merci à vous,

Après avoir désactivé le script ASP dans les paramètres de sécurité internet d’internet.

Je redémarre le navigateur et je n’ai plus le message d’erreur.

vendredi 26 décembre 2008 à 22h31

Bonsoir,
Pardon mais je suis vraiment nulle en informatique et j’ai pas tout compris, alors est ce que tu pourrais faire une "explication pour les nuls" s’il te plait ? ^^
Merci et bonnes fêtes.

dimanche 30 novembre 2008 à 15h49

Le dysfonctionnement sous IE 7 est corrigé, merci pour cette solution.

Logo de Clément
jeudi 30 octobre 2008 à 00h56 - par  Clément

EXCELLENT !! Je remercie fortement l’auteur de cet article qui m’a bien aidé !
Bonne continuation, et tous mes remerciements !

Site web : Mon SIte Gratuit
Logo de Ripley
mercredi 29 octobre 2008 à 18h00 - par  Ripley

Bonjour
J’ai ce problème avec pas mal de postes de travail dans ma boite, qui ont ce message lorsqu’il arrivent sur www.google.fr. Le problème survient sur IE6 & 7. Y aurait-il un patch IE pour remédier à ce bug ?
Merci d’avance

jeudi 19 juin 2008 à 11h41

Parfait !
Merci pour ces explications.

Besoin d'aide ? Votre site est en panne ? Demander l'intervention d'un spécialiste au 0 891 69 60 60 (France)

Navigation

Articles de la rubrique